1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SDT(loader) keeps crashing while loading mods

Discussion in 'Help' started by Dotar, Dec 7, 2015.

  1. Dotar

    Dotar Avid Affiliate

    Joined:
    Apr 25, 2012
    Messages:
    112
    Likes Received:
    4
    Hey,

    So I've come across to a very annoying crash.
    Very often (about 90% times) when I try to load a mod through the sdt modding -> swf mod.. my flashplayer crashes, same thing if I try to load a dialogue). Have tried few flashplayers, happens with all.

    These are the mods that I'm using while I use SDT(loader):

    FinishesCounter.swf
    VigourCounter.swf
    PleasureCounter.swf
    BreathCounter.swf
    HeldBreathCounter.swf
    allalphaslidersV5.swf
    CumInMouthCounter.swf
    TemplateExtensionV5_sby.swf
    penisrangeV5.swf
    superbreastV3.swf
    femalemasterbateV1.swf
    strandlimitV2.swf
    throatcumbulgeV2.swf
    cheekbulgeeditV2.swf
    swallow.swf
    animtoolsV14.swf
    breastfirmnessV1.swf
    futabreasts.swf
    deepthroatactionsV3.swf
    MakeHerCum_V1.0.swf
    autohueregV2.swf
    moreclothingV5.swf

    I tried removing everything except keeping the counters, the program still crashes while I try to load a mod(or a dialogue). I'm using the latest loader (v5.45)

    Otherwise sdt runs perfectly at high fps and never crashes...

    Is it possible that the main sdt folder is too full of files or that I have downloaded some corrupt file that keeps crashing loader everytime I try to load a mod from the main sdt folder?

    Edit: Also tried running as administrator
    Got a fairly high specced pc aswell, got no problems running the game.

    I'm running out of ideas and this is really killing me :(

    Any ideas would be highly appriciated.
     
    Last edited: Dec 7, 2015
  2. stuntcock

    stuntcock Club Regular Staff Member Moderator

    Joined:
    Jun 5, 2012
    Messages:
    1,522
    Likes Received:
    355
    Which mod? Is there some specific mod which triggers the crash, or literally any SWF file will do it?

    The template extension should appear at the top of your list for compatibility reasons. There are some other mods which will load incorrectly (or not at all) unless the template extension precedes them. This probably isn't the source of your current problem, though.

    I don't recognize these mods. Probably not the cause of your current problem.

    What's the exception given? Try running the game under Flash Projector Content Debugger (available here) and copy-paste the error message.

    Unlikely. SDT doesn't care about files in its main folder. It doesn't care about excessive files anywhere, because it loads only those files which it's specifically instructed to load (e.g. via the configuration lines in moreclothingV5_1settings.txt).

    One possibility is that you've accidentally damaged or removed a Settings files which one of your mods is expecting. But most mods will simply revert to defaults (and/or complain loudly) in this case; I don't know of any which would crash the game.

    Possible but unlikely, since you're already tried disabling your mods and that didn't fix anything.

    There are some adjustments to Settings.txt which can crash the game (e.g. setting a negative friction value for semen strands, which can quickly generate an overflow error). But this would usually occur during actual gameplay rather than mod-loadig.

    I would guess the most likely problem is residual content-mods based on the active character. SDT will attempt to load the previously-used character (from the previous gameplay session) during startup. If that character comes from a folder with a Mods.txt file, then it will attempt to load those mods also. If some of those files are missing or corrupt, then the game may be left in an unstable state.

    Try starting the game and then immediately hit the Reset button (don't try to load any custom SWFs). If the game doesn't immediately crash, then close it and restart. You should see SDChan against a default background with no fancy stuff. Attempt to load a custom SWF file. If the game doesn't crash, then we can tentatively consider the problem fixede. Gradually re-fill your Mods.txt file (restarting the game after each addition) and ensure that you can still load custom SWF files manually during gameplay.

    If this process works, then try to identify the custom character (and/or character folder) which was responsible for the crash, and delete it. You can rebuild it in the future, but it would be stupid to leave it in-place -- an errant click could trigger the problem all over again.

    If this process doesn't work (e.g. because Reset simply crashes the game) then try running SDT.swf instead of Loader.swf. See whether you can successfully get the Reset to work there. If so, close the game and try to run Loader.swf. Then proceed with the Loader troubleshooting stuff (e.g. check whether you can successfully load a SWF file, and gradually re-enable your various startup mods).
     
    Dotar and sby like this.
  3. sby

    sby Club Regular Content Creator

    Joined:
    Sep 11, 2012
    Messages:
    1,337
    Likes Received:
    76
    as stuntcock linked, the content debugger can really help.

    also, i have come across weird in-game settings left over from a previous session (usually when devving a mod) that are stored that cause the game to crash. if you think it might be this, you can try to find your in-game data by looking at your windows login user's application data folder. one easy way to tell if this is the cause is if you rename your loader folder something else, and then when you start the game up you should have a brand new sdt savefile. if the game still crashes when you load your thing through the menu, then there is like a 70% chance it is a bug in one of my mods, since it seems you are using many of them xD. you can get your old savegame data back by simply renaming your loader folder back to what it was.

    could upload your loader folder and see if i can recreate the error, i always use the content debugger.
     
    Dotar likes this.
  4. Dotar

    Dotar Avid Affiliate

    Joined:
    Apr 25, 2012
    Messages:
    112
    Likes Received:
    4
    Hey,

    Thanks for the in-depth answers.
    Can't seem to get quotes working on this forum O_o

    Anyhow stuntcock asked which mod crashes the sdt. It happens when I click "load mod", it goes for my sdt root folder and crashes 1-2 seconds later without me even managing to load a mod in-time.

    Thx for the tip on templateExtension thingy.

    I managed to do a work-a-round that doesn't crash the game, I moved all the mods that I would use to a empty folder on a diffirent folder (not sdt root), moved dialogues & animtool positions there aswell). Now the loader isn't crashing anymore, bizarre...

    However if the problem starts appearing again, I will definitely try the Flash Projector Content Debugger and post results here.

    Thanks for the swift answers and I'll keep you posted if the problem starts appearing(again). :)