1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

firefox doesn't start .swf

Discussion in 'Help' started by Aniir, Oct 11, 2011.

  1. Aniir

    Aniir Potential Patron

    Joined:
    Oct 10, 2011
    Messages:
    3
    Likes Received:
    0
    Since I updated firefox and flash I can't get any .swf to start. It just pop a window asking me to either open or save the file. Opening opens a new tab and the same pop-up windows appear. Saving it makes a copy of the files.

    Any thought?
     
  2. anonymous

    anonymous Club Regular

    Joined:
    Feb 16, 2011
    Messages:
    2,925
    Likes Received:
    10
    Tools>Options>Applications

    Find SWF and all SWF entities and select them to use the plugin for firefox.

    SWF Movie should be enough I think.
     
  3. Aniir

    Aniir Potential Patron

    Joined:
    Oct 10, 2011
    Messages:
    3
    Likes Received:
    0
    Thank you very much! :D
     
  4. edge

    edge Potential Patron

    Joined:
    Oct 28, 2011
    Messages:
    2
    Likes Received:
    0
    So, I've got the same problem here (opening the application just prompts firefox to ask what should be used to open it), but when I try to associate the flash plugin with SWV under applications, well, the option just isn't there.

    Odder still is that I opened SDT last night. Ran fine. Didn't change any of this stuff over-night... What's changed?
     
  5. ModGuy

    ModGuy Club Regular Content Creator

    Joined:
    Feb 17, 2011
    Messages:
    1,754
    Likes Received:
    22
    Perhaps you need to reinstall the firefox flash plugin?
    http://www.filehippo.com/download_flashplayer_firefox/
     
  6. eyesNteeth

    eyesNteeth Guest

    Having the same problem. Reinstalled the flash plugin and it still didn't work.
     
  7. edge

    edge Potential Patron

    Joined:
    Oct 28, 2011
    Messages:
    2
    Likes Received:
    0
    Concur with the above. Reinstalled Firefox, the addons, and redownloaded the application. Nothing changed.
     
  8. anonymous

    anonymous Club Regular

    Joined:
    Feb 16, 2011
    Messages:
    2,925
    Likes Received:
    10
    Try what I told you to do, it should fix it.
     
  9. Aniir

    Aniir Potential Patron

    Joined:
    Oct 10, 2011
    Messages:
    3
    Likes Received:
    0
    It did, but recently I've been unable again. All the options are using the plugin for firefox. Except one but the option for the plugin isn't appearing in it. (swf file (unknown/unknown) is it's name
     
  10. Spiky

    Spiky Potential Patron

    Joined:
    Sep 30, 2011
    Messages:
    13
    Likes Received:
    0
    Same problem with Firefox and Flash. I tried Anonymous advice, I think I followed it correctly. It didn't work.

    Now I'm using Google Chrome just to play SDT.
     
  11. anonymous

    anonymous Club Regular

    Joined:
    Feb 16, 2011
    Messages:
    2,925
    Likes Received:
    10
    Personally, I'd just stick with the stand alone player, it is much more reliable.
     
  12. part

    part Potential Patron

    Joined:
    Nov 15, 2011
    Messages:
    3
    Likes Received:
    0
    Had identical problem, this fixed it.

    If problems arise or if you want to restore the default set of file download actions, do the following [8]:

    Type about:config into the address bar.
    Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.
    Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.
    Open the profile folder. (The profile folder is hidden by default in Windows 7/Vista/XP/2000 and Linux; read this for help finding it).
    Note: In Firefox 3.6 and above you can open the profile folder from the Firefox menu, via "Help -> Troubleshooting Information".
    Completely close your Mozilla browser.
    Delete (or rename) the file mimeTypes.rdf. Caution: There is also a mimeTypes.rdf file in the program folder. Do not delete it by mistake.