1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Making mods for SDT

Discussion in 'Help' started by jarhead70, Aug 5, 2012.

  1. jarhead70

    jarhead70 Potential Patron

    Joined:
    Feb 9, 2012
    Messages:
    48
    Likes Received:
    0
    Hi,

    Maybe this was already asked somewhere in this forum (anyone point me to it?), but what do I need to make mods for the official SDT? To be precise, what Adobe Flash version is the minimum? Further more, are there any free/open source alternative to Adobe Flash which have the minimum functionalities (like drawing vector graphics, aside for compiling) for making SDT mods? Can programs like Vectorian Giotto be used? Does SDT mods require AS3 script functionalities?

    Also, for open source route, I have no problem whatsoever with CLI (Command Line Interface) programs, and mix-matching several programs at once (like using InkScape for vector graphics, and using some kind of CLI compiler like SWFTools). I just don't know what combo works, at least as far as making SDT mods go.

    Thanks
     
  2. Maineim

    Maineim Casual Client

    Joined:
    Nov 27, 2011
    Messages:
    274
    Likes Received:
    2
    Thanks for the tip, I will try this free to use alternative.

    But as far as I know SDT was done with actionscript 3, not fully supported in this program, but I don't konw nothing AS3 and the code of SDT to test it.

    I tried Vectorian Giotto on Linux, and the program installs and runs, but I couldn't import any external format. :'(
     
  3. Faceless

    Faceless Club Regular Content Creator

    Joined:
    Jun 12, 2011
    Messages:
    1,118
    Likes Received:
    22
    Considering that the template includes AS3 snippets, you'll at least need a program that's capable of compiling those snippets. Which pretty much means Flash CS (I think it's up to 6 now). The problem, of course, is that Flash CS costs $700. Yeah.
     
  4. chrigoog

    chrigoog Guest

    Well, not necessarily:
     
  5. jarhead70

    jarhead70 Potential Patron

    Joined:
    Feb 9, 2012
    Messages:
    48
    Likes Received:
    0
    At least this clarifies that SDT mod requires AS3. I've search around some more and find only Adobe Flash can open FLA (the mod references). I've got some idea on getting around that. However, if Adobe Flash should be used, what's the oldest version which still can compile something SDT can read? SDT mods doesn't need cutting edge Adobe Flash Studio does it?

    Umm, care to elaborate what is "not neccessary"? :-[
     
  6. anonymous

    anonymous Club Regular

    Joined:
    Feb 16, 2011
    Messages:
    2,925
    Likes Received:
    10
    He was linking offsite to an illegal download of Flash.

    I think safest is CS5, but you can do CS4 or 3 if someone will provide you with a proper template, as there are only CS5 and 5.5 templates out there (sometimes 4) and older versions don't read newer templates.