Yoko Littner Dynamic hair bug

VorstVolxen

Potential Patron
Joined
Dec 15, 2015
Messages
16
First off: I'm not *entirely* certain if this is the right place to post this? Thus I'm sorry if this was meant to go in a different topic (I am an idiot :'D), but I digress...

I downloaded the standalone version of Yoko's hair by sclover13, and for some reason that I am completely unsure of; the bangs of her hair are not part of her hair. Instead, they're floating besides her, with her shoulders.
Never had this happen with any hair swf mod before, so I'm pretty confused.

Not entirely sure if this is a problem on my end, or with the swf file itself.
But in the preview images sclover13 had for this hair, it looked completely fine.
 
Last edited by a moderator:

sby

Content Creator
Joined
Sep 11, 2012
Messages
1,852
First off: I'm not *entirely* certain if this is the right place to post this? Thus I'm sorry if this was meant to go in a different topic (I am an idiot :'D), but I digress...

I downloaded the standalone version of Yoko's hair by sclover13, and for some reason that I am completely unsure of; the bangs of her hair are not part of her hair. Instead, they're floating besides her, with her shoulders.
Never had this happen with any hair swf mod before, so I'm pretty confused.

Not entirely sure if this is a problem on my end, or with the swf file itself.
But in the preview images sclover13 had for this hair, it looked completely fine.

tried this out with and without init mods, got same result.
i tried it out with an old loader 5.1 also, same result

was mostly making sure it is something i didn't break xD
 

VorstVolxen

Potential Patron
Joined
Dec 15, 2015
Messages
16
tried this out with and without init mods, got same result.
i tried it out with an old loader 5.1 also, same result

was mostly making sure it is something i didn't break xD

That's...Really odd.
I wonder why it's doing this then?

Definitely has to be the .SWF at fault, which is a shame, really. I quite like Yoko without those glasses.
Too bad the artist is inactive too. :'D

*EDIT*
I just tried it in vanilla SDT, and the hair mod works fine.
Now I'm more confused o:
 

stuntcock

Club Regular
Joined
Jun 5, 2012
Messages
2,415
Definitely has to be the .SWF at fault
It's the combination of the hair mod itself (which uses non-standard offsets and gravity vectors) and animtoolsV14 (which asserts control over gravity vectors).

This bug is mentioned in the Resource description.

It can be fixed by recompiling the mod with extended physics (which would make it a Loader mod -- incompatible with the vanilla game) or by asking sby sby for an animtools patch to correct the original problem.
 

VorstVolxen

Potential Patron
Joined
Dec 15, 2015
Messages
16
It can be fixed by recompiling the mod with extended physics (which would make it a Loader mod -- incompatible with the vanilla game) or by asking sby sby for an animtools patch to correct the original problem.

Right...Hm.
I'm not sure how to do the former, I'm sorry to say. Unless if there's a tutorial that I couldn't find.

Though yeah, it'd probably be easier just waiting for sby to patch it.
 

sby

Content Creator
Joined
Sep 11, 2012
Messages
1,852
i believe i have fixed the gravity direction vectors in animtools v15, however the bangs being detached is still present as before.

and as i mentioned before, i saw the issue in a fresh loader without any init mods. try it and see for yourself if you still think this is an animtools thing
 

VorstVolxen

Potential Patron
Joined
Dec 15, 2015
Messages
16
Yeah, I just tried it out and saw exactly what you meant now.

I had figured it'd be to do with gravity vectors or whatever, but...Yeah, it's just incompatible with the loader it seems.
I'll just have to wait and see if Sclover13 manages to fix this.

Though hey, look at the bright side, at least this little investigation fixed something in the end. :P
 

stuntcock

Club Regular
Joined
Jun 5, 2012
Messages
2,415
I'll just have to wait and see if Sclover13 manages to fix this.
Unlikely. sclover13 sclover13 last visited SDTMods in October 2015 and hasn't ever been seen on the Undertow website. The last actual activity (ie. forum posting) is from early 2014.

Click the "watch this Download" link on the Yoko Littner Hairstyle page. If I decide to fix it then I'll post the new SWF as an update to the original, and you'll receive an automatic notification message.
 

Antimatter42

Content Creator
Joined
Sep 2, 2017
Messages
393
Looks like I did fix this already. Check.
Sorry, but do I check the resource manager to see if the hair has been fixed? I just downloaded a copy of your hair, and still have the bug when I use it on the loader. I also checked your thread, and ended up downloading the same file.
 

sclover13

Content Creator
Joined
Nov 29, 2012
Messages
281
Sorry, but do I check the resource manager to see if the hair has been fixed? I just downloaded a copy of your hair, and still have the bug when I use it on the loader. I also checked your thread, and ended up downloading the same file.
Hm. I'll look into it. The swf I have has the fixed hair. I'll get back to you as soon as I have it resolved for sure.
 
Top Bottom