Connection almost impossible from a Mac

Kopamon

Potential Patron
Joined
Jan 4, 2013
Likes
6
#1
Chrome-Mac-Bug.png
I'm using a Mac Pro with 10.6.8, because the machine don't works with 10.9 and 10.7-10.8 have issues with SSL. I'm able to connect to forum using an old version of Safari (5.1.10). Chrome (49) and Firefox (48), give me an "Inadequate Security Error". Firefox says "Administrator should update server software". It's a problem, because I'm getting rid of Safari 5.
Here is a screenshot of Chrome with Developer Tools active. Since Chrome on a Mac force to use the system-selected language and I'm not an english speakers, I added an english translation (the purple words).
Any hints?
 

detritus

angry angry
Staff member
Administrator
Moderator
Ryonani Teamster
Joined
Nov 23, 2009
Likes
167
#2
I'm unable to reproduce this error with Chrome 59/60, Firefox 54, Edge 38, or IE11. Can't test with Safari since it's no longer developed for Windows.

I'm fairly certain this is an issue with your browsers being out of date. I'm not a Mac/OSX user so unfortunately I can't provide much support, but Chrome 49 and Firefox 48 and earlier have known issues with certain encryption ciphers for HTTP/2. If you can't install a version newer than that, it's because your OS is too old and most likely no longer supported.
 

Kopamon

Potential Patron
Joined
Jan 4, 2013
Likes
6
#3
I'm unable to reproduce this error with Chrome 59/60, Firefox 54, Edge 38, or IE11. Can't test with Safari since it's no longer developed for Windows.

I'm fairly certain this is an issue with your browsers being out of date. I'm not a Mac/OSX user so unfortunately I can't provide much support, but Chrome 49 and Firefox 48 and earlier have known issues with certain encryption ciphers for HTTP/2. If you can't install a version newer than that, it's because your OS is too old and most likely no longer supported.
I can confirm this, sadly.
SSL Server Test (Powered by Qualys SSL Labs)
Testing undertow.club from this page shows both FF 48 and GC 49 treat this site as "blacklisted".
Never mind, I'll simply stick with Safari - or SeaMonkey - until I change my Mac.
Thanks anyway.
 
Top Bottom